Kernels nuevos en Debian Jessie

Vengo siguiendo bastante de cerca la publicación de versiones estables del kernel de Linux. A fines de diagnóstico suelo compilar la última versión disponible e instalarla en varias de las máquinas sobre las que tengo acceso. Como quizás le sirva a más de uno, acá dejo disponible la última versión que compilé en casa.
Todas estas son directamente instalables sobre Debian GNU/Linux 8.0 Jessie de 64 bits sin quilombo de dependencias. Cada directorio contiene los paquetes con la imagen del kernel, los encabezados, el firmware y la configuración utilizada en la compilación.

Si les interesa saber qué hay de nuevo, les dejo el resumen de Diego Calleja, un post de Phoronix donde se listan algunas de las mejoras e incorporaciones, y el clásico resumen hecho por la gente de KernelNewbies.
A medida que vayan saliendo nuevas versiones iré actualizando este pequeño “repositorio” para mantenerlo al día.

Actualización 2017: en función a la reciente publicación de la nueva versión estable Debian GNU/Linux 9.0 Stretch, y tras haber migrado los equipos que utilizo habitualmente, este repositorio dejará de alojar versiones de kernel pues no podré compilarlos para la versión Jessie. Les recomiendo actualizar la versión del sistema operativo y, en caso de preferir versiones de kernel más modernas, utilizar aquellas disponibles en los repositorios Sid y/o Experimental.

Add a comment »8 comments to this article

  1. You are doing a great job, comrade – thank you very much …

    Reply

  2. kernel 4.11.0 not working

    Reply

    • Thanks for your report. I haven’t had time to test it yet.
      I’ll promise to take a look. Meanwhile, any relevant error message?

      Reply

  3. New kernel 4.11 not working

    Reply

  4. Error! Bad return status for module build on kernel: 4.11.0 (x86_64)
    Consult /var/lib/dkms/nvidia-current/375.39/build/make.log for more information.

    Cc1: some warnings being treated as errors
    Scripts / Makefile.build: 294: recipe run error for the target “/var/lib/dkms/nvidia-current/375.39/build/nvidia-uvm/uvm_utils.o”
    Make [2]: *** [/var/lib/dkms/nvidia-current/375.39/build/nvidia-uvm/uvm_utils.o] Error 1
    Makefile: 1492: recipe run error for the target “_module_ / var / lib / dkms / nvidia-current / 375.39 / build”
    Make [1]: *** [_module_ / var / lib / dkms / nvidia-current / 375.39 / build] Error 2
    Make [1]: exit the directory “/usr/src/linux-headers-4.11.0”
    Makefile: 81: failed to execute the recipe for the purpose of the “modules”
    Make: *** [modules] Error 2

    Reply

    • Thanks! Oh, right… it happened to me as well, but with the Radeon module.

      There have been some changes on the API in kernels version 4.9 ~ 4.11. Some of these changes affect modules built with the dkms infrastructure, like drivers for Nvidia and ATI Radeon GPUs.

      This means that the kernel is built and works OK, but unfortunately at least until a patch is developed (and applied) to those modules (nvidia-kernel-dkms, fglrx-modules-dkms), we won’t be able to use propietary drivers with Linux 4.11.

      I’m sorry, but there’s not much that I can do. We’ll have to wait a little bit.

      Reply

  5. 4.10.17 Empty?

    Reply

Copyright © All Rights Reserved · Green Hope Theme by Sivan & schiy · Proudly powered by WordPress